GLC 300 - COMAND Dropping Pre-sets - Mercedes GLC Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-03-2019, 10:21 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 1
(Thread Starter)
GLC 300 - COMAND Dropping Pre-sets

Thanks for this forum . . I have a minor irritation that I began experiencing with COMAND and I was wandering if it was just me. About every 4-6 weeks, COMAND will randomly drop my pre-set satellite radio channels. It will keep the FM/HD/AM channels but drop the SAT channels. I took the it to one of the dealerships in Northern VA (Fredericksburg) and of course nothing happened after several randomly channels were set and was told maybe its just a one-time glitch. Weel this one time glitch happens every other month or so . . anyone in the same boat?
post #2 of 3 (permalink) Old 07-09-2019, 09:14 PM
Junior Member
 
Join Date: Nov 2018
Location: Boston, MA
Posts: 1
Per my dealer this is a known issue. Happens again and again without any rhyme or reason. Like in your case, only SAT channels disappear. What I started to do instead of reprogramming all our pre-set channels: store the settings on a USB stick and then reload the settings once the channels disappear.
Dreuther is offline  
post #3 of 3 (permalink) Old 07-11-2019, 10:32 PM
Junior Member
 
Join Date: Feb 2019
Location: Northern Virginia
Posts: 15
I have the same problem as well on my 2019 GLC 300. It drives me but when that happen and highly annoying. How do you save the preset settings to USB and restore it?

Stargazer
stargazer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes GLC Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome