Mercedes GLC Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I thought I would share this experience in case it helps others. We recently started hearing a creaking sound from the front of the car - sounds like an old wooden boat, creaking wood kind of sound from front middle of car. I have experienced this in a Nissan Murano I have had and it ended up being a costly repair - something with the front struts/ boots / arms / suspension - I don't remember exactly but it happened and cost us like $2000 to fix.

Luckily though, this was repaired at no charge - when I explained it to dealer they knew what is was right away - something about a loose dust cover on the suspension. I will find out more detail and update this post. It seemed very common.

Anyways, just hoping to calm the fears of someone else if they run into this.
 

·
Registered
Joined
·
287 Posts
This definitely seems very common if they knew straight off the bat, really looking into hearing some more in depth info about this.. Thanks for bringing this up to attention though
 

·
Registered
Joined
·
1 Posts
Had the same issue and it was fixed under warranty...here is the fix as it was described:

1332 THE EXAPANSION OF THE FRONT STRUT STOP BUFFER ALLOWS THE BOOT TO COME IN CONTACT WITH CASING OF THE HEAD BEARING MAKING NOISE; CHECK AND ROAD TESTED-- 1332-1336- AND CONFIRMED WITH LI32.25-P-063651 NOISE RECORDING . CHECK AND RAISED VEHICLE ON LIFT - PERFORMED LI AND APPLIED GREASE IN THE SPECIFIED AREAS OF THE BOTH FRONT STRUTS . AREA SURFACE BETWEEN SPRING AND THE SPRING CUP SUPPORT, ARE SURFACE BETWEEN THE DUST BOOT AND THE STRUT TOWER, GREASED SHOCK ABSORBER PISTON AND STOP BUFFER. ROAD TESTED 1336-1340-- NO MORE NOISE
 

·
Registered
Joined
·
287 Posts
Thanks a bunch ! I know there's a few members on here that have been having this issue, so it'll be great to direct them to this thread
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Round Two to ongoing issue

Update: Picedup car after getting recall taken care of and the "dust boot" problem - or so I thought. Problem still occurring right away when I left dealership. They have another experiencing same problem within 24 hours. "Has been escalated to engineering in germany" I was told ... but not something we couldn't drive with. So the plan is they are going to figure out what is going on with the one they have in the shop now and then when they have that fix, they should be able to apply it to my car as well. We shall see - being hopeful!
 
1 - 5 of 5 Posts
Top