Mercedes GLC Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone,

This is my first post. I have had my GLC almost and year and I love it. But lately I have been having some bluetooth issues and I wanted to see if anyone else has seen anything like this. I have an iPhone 6s running 10.2.1. My phone drops constantly from bluetooth. I can tell because I see it drop off then a few seconds later you see the window showing it is connecting to the phone. At times it reconnects quickly but then there are times when it seems to take almost a minute or so to connect. I will be doing absolutely nothing with the phone, it will just be sitting there on my lap and it will disconnect. There are also times when I will be in the middle of a call and it just drops when it does it will sometimes reconnect and other times it won't. I tried my wife's Audi A4 today and it connected fine and stayed connected (although she also has CarPlay which is much better, why can't we get!!). I looked at Apple forums and have tried unpairing, forgetting the device, resetting my network settings, everything they suggested. I even got a replacement phone and this one seems even worse. I am not sure if it is the car or the phone. I did notice today that my Apple Watch disconnected and reconnected at least once that I saw, so it might just be the phone but it did work fine in the Audi. Anyone having any problems like this?
 

·
Registered
Joined
·
1 Posts
I use the Media Interface to play music as it is much better sound quality than bluetooth. I bought my car in January 2017 and I have an iPhone 6s. Everything was working fine until just this month (August 2017). Bluetooth doesn't connect either. For the Media Interface, even if it's connected via the cable, the car doesn't recognize the phone is connected. I didn't upgrade the phone iOS or changed anything in the car. I tried a bunch of suggestion from different websites. It's hit or miss. Sometimes it works, sometimes it doesn't. Did you find any solution to your issue since March 2017?
 
1 - 2 of 2 Posts
Top