Mercedes GLC Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello - New to forum. I have a 2019 GLC 300 that was purchased a week and a half ago. Car has 37K miles and in great shape. This past weekend, 3/4 - I had a dash cam installed. When I picked up the car, I heard the radiator/Ac fan(s) turn on and very loud. I didn't bother checking on the climate control because it was a cold day and i didn't really need heat or cold. Well, on Saturday 3/6 late in the afternoon, I turned on the car again, and you could hear the fans very loud. I attempted to check to see if ac was on and none of the lights are on (buttons) and they do not respond.. But in the display panel Under Climate Control, the setting for Climate Control is on, but the ac is unchecked or off. When I click on ac, it checks the box, but then immediately unchecks itself. I tried it with car on and also with the car in the accessory mode, and not on, and it is the same behavior. I tried it with the screen controls with rotary wheel and also using the "fan speed button" to turn the climate control off. None of the buttons are responding.

I checked the owners manual as well as the owners manual within the controls and I tried the suggestions and it will not turn on.

Am I missing something> Is there a menu I need to access or a button sequence i need to toggle?

Any support would be greatly appreciated. I am taking it to the shop that installed dash cam but I doubt they will know what they did if indeed something they did caused this issue.

-Agustin
 

·
Registered
Joined
·
1 Posts
Hello - New to forum. I have a 2019 GLC 300 that was purchased a week and a half ago. Car has 37K miles and in great shape. This past weekend, 3/4 - I had a dash cam installed. When I picked up the car, I heard the radiator/Ac fan(s) turn on and very loud. I didn't bother checking on the climate control because it was a cold day and i didn't really need heat or cold. Well, on Saturday 3/6 late in the afternoon, I turned on the car again, and you could hear the fans very loud. I attempted to check to see if ac was on and none of the lights are on (buttons) and they do not respond.. But in the display panel Under Climate Control, the setting for Climate Control is on, but the ac is unchecked or off. When I click on ac, it checks the box, but then immediately unchecks itself. I tried it with car on and also with the car in the accessory mode, and not on, and it is the same behavior. I tried it with the screen controls with rotary wheel and also using the "fan speed button" to turn the climate control off. None of the buttons are responding.

I checked the owners manual as well as the owners manual within the controls and I tried the suggestions and it will not turn on.

Am I missing something> Is there a menu I need to access or a button sequence i need to toggle?

Any support would be greatly appreciated. I am taking it to the shop that installed dash cam but I doubt they will know what they did if indeed something they did caused this issue.

-Agustin
Did you figure it out I am having the same issue
 
1 - 5 of 5 Posts
Top