Mercedes GLC Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi All
New to the Forum but looking to see if anyone else is experiencing issues with front Parking sensors on the new 2020 GLC.
Picked it up on 1st March and love the car but already its been back for a snagging list. Didn't have any issues with parking sensors until I got it back from this visit back to the dealership. Non of the issues should have had anything to do with the parking sensors. Both left and right parking sensors adjacent to the number plate on the front intermittently go immediately red when vehicle stops and reversing camera opens up and screen indicated to check entire surroundings. Have spoken to the dealership again and they inform me that there is a technical bulletin with Mercedes that the Number plate bezel and mount may interfere with the parking sensors. Surely if this was the case. there would be a lot of GLC's out there experiencing the same issue??? They want to remove the number plate mount which quite frankly would make it look a bit odd.
Any comments or recommendations would be appreciated.
Thanks in advance.
 

·
Registered
Joined
·
19 Posts
Hi Andy, I have a new GLC300 AMG Premium plus and have no issues with the parking sensors. So if it is the number plate bezel it must be down to how the dealers fit it. I have had 3 issues with the Command screen; it has not activated when I started the car (and I hadn't turned it off). This issue fixed itself after the car was turned off and restarted the following day.
 
  • Like
Reactions: Andy Horsman

·
Registered
Joined
·
121 Posts
There’s a sure way of knowing by removing the mount yourself and road test...
x4 Philips screw hold the number plate to mount, once removed there’s a couple of screws that hold the mount to the bumper.
Do you have the front camera (part of the 360degree package I believe) is it possibly needing calibrated
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Hi Andy, I have a new GLC300 AMG Premium plus and have no issues with the parking sensors. So if it is the number plate bezel it must be down to how the dealers fit it. I have had 3 issues with the Command screen; it has not activated when I started the car (and I hadn't turned it off). This issue fixed itself after the car was turned off and restarted the following day.
Would you mind taking a photo of your front plate and mount if you get a chance (obviously obliterating the Reg) so I can compare the plate mount against mine.
Thanks in advanace.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
I can see what the dealer means now. The bottom edge of the plate holder is thicker because it bears the dealers name and this caused the plate holder to be about 20mm lower than it should be. This dealer sells hundreds of cars. I have to ask how come I'm the only one with an issue??? My car obviously has a different front end to yours. Thanks for the photos.
 

Attachments

·
Registered
Joined
·
121 Posts
I ”believe” with that plate surround, the lower plate is snapped in with plastic clips and can be levered out and off.
then the plate can be slid down and out, the plate holder/surround has multi holes for screw fitment to OEM plinth
Removing the surround may resolve issue, though I guess it is a dealer issue really, regardless of how simple the resolution may be
Prior to plate change, with dealer plates fitted there was a lower banner, albeit the lower outer edges were trimmed level with std plate size.
I guess I now know the reason!
 

·
Registered
Joined
·
19 Posts
Would you mind taking a photo of your front plate and mount if you get a chance (obviously obliterating the Reg) so I can compare the plate mount against mine.
Thanks in advanace.
Andy, here you go.
3393
3394
F4A895AB-AE1C-4095-8C10-E17A3D779910_1_201_a.jpeg 4E318BB5-001F-4B57-990F-060B8780269E_1_201_a.jpeg
 
  • Like
Reactions: Andy Horsman

·
Registered
Joined
·
7 Posts
I have noticed a sensor problem with my new Glc300 2020 model that when you lock the steering to the right, the right sensor goes on red alert. I took it to Mercedes but they couldn’t replicate the problem however I noticed it again yesterday. Has anyone else experienced that issue? Do you think the sensor is so sensitive that it is picking up the car wheel when turning??
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
I have noticed a sensor problem with my new Glc300 2020 model that when you lock the steering to the right, the right sensor goes on red alert. I took it to Mercedes but they couldn’t replicate the problem however I noticed it again yesterday. Has anyone else experienced that issue? Do you think the sensor is so sensitive that it is picking up the car wheel when turning??
Did you notice on the MBUX which sensor flagged. There is obviously 3 for the left and 3 for the right. My dealership has told me that there is a technical alert from Mercedes regarding the license plate holder interfering with the parking sensors. This however flags the sensor nearest the plate holder. From your description is it your outer sensor flagging?
 

·
Registered
Joined
·
7 Posts
It would a the right sensor near the front door which is lighting up like a Christmas tree, not the front sensors.
 

·
Registered
Joined
·
54 Posts
As I understand it there are no sensors down the side of the car, just assumption based alerts (ie if the front sensor picked something up to the outside of the car and you then drive forward that thing must now be beside the car).

So I guess the one right on the side of the bumper is tripping?
 

·
Registered
Joined
·
7 Posts
As I understand it there are no sensors down the side of the car, just assumption based alerts (ie if the front sensor picked something up to the outside of the car and you then drive forward that thing must now be beside the car).

So I guess the one right on the side of the bumper is tripping?
 

·
Registered
Joined
·
7 Posts
thanks. I might film this issue occurring so I can take it back to Mercedes as although it is rare (that you lock the steering wheel right), it is quite alarming when all the right hand sensors go red and scream when there is nothing there.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #15
Update - Bezel was changed by the dealership for a slimline one that is leas intrusive that the original one on the parking sensors. This has made no difference at all. When the weather is dry they work fine but when it has rained or I have washed the car and dried it off they start randomly activating them again. I have replicated the fault. Its definitely water related. Back to the dealership again for further investigation. Not good for a brand new Car.......
 

·
Registered
Joined
·
11 Posts
Discussion Starter #16
Update no 2.
After another visit, apparently a software update has sorted the random activation of the front sensors. 4 weeks in and not a beep. Hope that’s it sorted. Fingers crossed.
 
1 - 18 of 18 Posts
Top