Mercedes GLC Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a loud noise that appears to come from fan even when the fan is off. It is intermittent and can last for 5 to 10 minutes at a level that is too loud for conversation.

Model is 300 GLC 2020 with 10k on the odometer. Dealership does not appear to be able to identify the issue.
 

·
Registered
Joined
·
46 Posts
I have a loud noise that appears to come from fan even when the fan is off. It is intermittent and can last for 5 to 10 minutes at a level that is too loud for conversation.

Model is 300 GLC 2020 with 10k on the odometer. Dealership does not appear to be able to identify the issue.
I had this for the first time this week. Pulled up and got out of the vehicle. Noticed a very slight burning smell and the fan noise. It lasted a good 5 mins or so before shutting off. It was only a small journey and in cold weather so should have no over heating issue. I may need to keep an eye on this if it is potential problem. Not had it before.
 

·
Registered
Joined
·
3 Posts
Hi, I was just wondering if your issue got resolved. I have the same exact problem only it comes on after driving apprx. 20-30 minutes. Brought it to Mercedes service where they're telling me they are seeing this problem with the new glc 300 2020 but has not been an issue in previous years. They said the mbux gets too hot so there is a fan that turns on to cool it down ... does this sound normal?!! I spoke with someone at customer service to see what can be done but this is unacceptable and not what you would expect from a luxury vehicle.
 

·
Registered
Joined
·
1 Posts
Hi. I too have the same problem. It’s highly intermittent and seems to happen only sometimes after driving for 20-30 mins. I took it into MB and they told me it could be one of the fans on the console but would need to observe it when it happens. Lol. Good luck with that because it doesn’t last long. I took some video of it though which I will post if I can. My glc 300. 2020



Hi, I was just wondering if your issue got resolved. I have the same exact problem only it comes on after driving apprx. 20-30 minutes. Brought it to Mercedes service where they're telling me they are seeing this problem with the new glc 300 2020 but has not been an issue in previous years. They said the mbux gets too hot so there is a fan that turns on to cool it down ... does this sound normal?!! I spoke with someone at customer service to see what can be done but this is unacceptable and not what you would expect from a luxury vehicle.
 

·
Registered
Joined
·
81 Posts
Could well be a cooling fan for the MBUX which is essentially a computer system, a PC has a cooling fan for the same reason
 

·
Registered
Joined
·
46 Posts
I find it hard to believe this is for the MBUX, why would it overheat after that specified time. Longer and shorter trips don;t appear to trigger the fan.
 

·
Registered
Joined
·
58 Posts
It may be perspective but the photos look different to the overhead of my MBUX (which has a lot of vents down both sides).

Either way, PCs need to cool down normally by a big heatsink and then by fan if necessary. If your fan is coming on often (I've never heard mine) then perhaps the heatsink isn't making proper contact with the cpu and it's overheating?
 

·
Registered
Joined
·
3 Posts
Im not sure, Im not too familiar with these terms. All they're telling me is that the mbux in the new glc 2020 has been placed too close to the engine in the front and the fan that comes on to cool it off has 3 speeds on it and it comes on at the 3rd fan speech which happens to be loud. Service manager says it will be an issue for everyone come summer time since it will be hot out and the fan will turn on right away. He said its basically a design flaw and could be fixed if Mercedes comes out with a recall and moves box but so far Mercedes is saying this is "normal" and is doing nothing about this issue. Frustrating to hear their service manager say this is an issue and agree with the customer yet Mercedes does nothing and brushes you off.
 

·
Registered
Joined
·
58 Posts
I wonder if it's region specific, I've had my GLC 300 2020 model out and about here in Sydney on a 43.5 degree day (celcius) and it was silent.
 

·
Registered
Joined
·
3 Posts
So it seems its not happening with all of them. I think I'm going to request to drive a loaner and see if I hear the same sound. Mercedes definitely knows about the issue but they're pretending like it is normal. Thank you for your feedback.
 

·
Registered
Joined
·
20 Posts
Is it a diesel ? If so then the engine was probably doing a DPF cycle when you turned it off so it runs the cooling fan to cool things down for a few mins after you turn it off. You will also smell a burning smell.
 

·
Registered
Joined
·
3 Posts
I have a loud noise that appears to come from fan even when the fan is off. It is intermittent and can last for 5 to 10 minutes at a level that is too loud for conversation.

Model is 300 GLC 2020 with 10k on the odometer. Dealership does not appear to be able to identify the issue.
Im having exactly the same issue with the 2020 GLC 300 I bought in April. I didn’t notice it until the summer heat came. Now it’s incredibly loud and it’s like that constantly. I took it to the dealer, and they said it’s “normal” and “they all do that.” I don’t care if they all do that, it sounds horrendous and I hate it. Unacceptable. Interestingly, I just happened to get my buyer survey in the mail this week. You can bet I’ll be lighting up about this!
 

·
Registered
Joined
·
1 Posts
I have been to Mercedes and apparently this is normal. It’s doing it’s dpf cycle. Happens with diesel cars. They spent hours testing
 

·
Registered
Joined
·
2 Posts
Hi guys, got the same problem with my GLC400d arrived in August. The problem was first noticed few days ago after rather a long driving on autobahn (220 km). When I just exited and slowed down, I noticed this annoying noise coming directly from the central console, from behind the vent openings, a bit below them. During the trip the noise disappeared and appeared again, usually it was quite during the first 10-15 minutes after start, and then appeared again. I supposed the reason is MBUX unit cooling, because the noise was very similar to a fan on small devices like a video adapter or CD-ROM (if your still remember what it is - and yes, it had a fan to cool it down).
Researching here and on other forums just confirmed it is MBUX. Since few days I have been trying to identify any relation between what MBUX is doing and when noise appears, because it does not come always. It seems I found something, and want to ask you for confirmation - whether you observe the same.
1. I noticed the noise appears primarily when I use Navigation.
2. Just navigation does not always cause the noise, but when it is used with AR (Augmented Reality) enabled on the map (that fancy blue arrow appearing on the top of the picture from the front camera) the noise comes almost immediately.
3. Sometimes the noise appears when I use audio commands for few consecutive orders.

Anyone having the same issue, could you please try to drive with MBUX enabled and doing navigation for 20-30 minutes with AR enabled and without it? Better you drive in a city, so AR is shown more often. Does disabling the AR make any difference to the noise?
 

·
Registered
Joined
·
2 Posts
Hi All. This is my post from another MB forum, but about the same issue. It seems I have got it finally solved.
First, I found out on other forum that there is MBUX SW update from FUP2 to FUP3 available for GLC. The update is not delivered OTA, you need to visit a service. I made an appointment just with a 'noise from the central console' complaint. They asked me to record a video with the noise if possible (understanding it can be not easy to reproduce) - so I did.
In the service several engineers looked at the video and concluded that "yes, the noise seems to be coming from electrical device and most likely it is MBUX head unit". The electrical specialist they invited to look at the video had just confirmed it. However he said the behaviour of the fan looks correct (it turns on to max speed immediately when triggered, and runs on max until the CPU is cooled down), but the noise itself is not right (too loud). He suggested to replace the head unit. I asked about SW update, but they were sceptical it can help - however agreed to try and order the new head unit in parallel.
Afternoon things developed further. They called me and said that replacement of HU will not help and Mercedes is strictly against it. They said all the HU are prone to this issue, it is caused by specifics of fan placement on the unit. But they gladly confirmed this is the known problem and it is fixed via SW update. In the FUP3 the behaviour of the fan is changed - they did not say how exactly, but from what I see it turns on a bit earlier but with minimal speed, so it helps to keep the unit constantly cool. It is barely heard now. So I have driven 700+ km after the update, including long runs for several hours, and have not heard this terrible noise again. So it looks the problem is solved.

One hint: save all your settings to you driver's profile via Mercedes Me app: the settings are lost during SW update.
Hope it helps.
 
1 - 18 of 18 Posts
Top