Mercedes GLC Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All.

I am new to the page. Unfortunately, all of a sudden the audio on my Burmester Sound System & my 360 Camera has stopped working on my GLC 250.

I have tried holding down the eject button and resetting the Command centre and I have had both batteries replaced this has not fixed the issue.

Any advice on what I can do or what to say to Mercedes as it is out of warranty :(

Any help is greatly appreciated!
 

·
Registered
Joined
·
2 Posts
Just checking to see if you've found a resolution for this yet? I had the same issue occur this morning and can't figure out who to fix. Display panel and rest are working fine otherwise - it's just the speakers and camera system for me. Thanks in advance.
 

·
Registered
Joined
·
2 Posts
Just checking to see if you've found a resolution for this yet? I had the same issue occur this morning and can't figure out who to fix. Display panel and rest are working fine otherwise - it's just the speakers and camera system for me. Thanks in advance.
this happened on my C220 which is basically same system. It was a dealer needed fix.
 

·
Registered
Joined
·
1 Posts
Newer models with proximity FOB....shutoff/park, lock the car, walk away at least 30+ feet and keep distance from it for at least 2 mins. This will allow shutdown of the car and essentially everything should reset. If not they probably have some software update. Had to do this for a stuck reverse camera. 2019 350e
 
1 - 5 of 5 Posts
Top