Mercedes GLC Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I wanted to share a recent issue I had with my GLC to see if anyone else has had this issue. I was leaving a light and accelerated to about 30mph. A car was making a left turn into a neighborhood about 100 feet in front of me. I pressed the brake and the car did not appreciably slow. I freaked out a bit and pushed the brake pedal to the floor. The car slowed to maybe 15 or 20mph as I approached the rear of the car. Traffic was in the right hand lane and I could not cut over. About 10 to 20 feet from the back of the car, I heard a noise and the car attempt to slow through the pre-collision assist. It did not stop the car but slowed it down to between 5 and 10mph. I hit the rear of an Altima. At that time I noticed the warning that pre-collision assist was inoperative on the dash.

The resulting damage was a dent to the truck and bumper of the Atlima, a dented hood for me and damage to the plastic front fascia of the car. I moved it off the main road and exchanged information and then waited about an hour for roadside assistance to come tow the car.

It was towed to the dealership and I opened a case with Mercedes NA. It has been a week and they have been pulling data from the car. They have not shared any details with me. The Service Manager did indicate they found a fault from the pre-collision assist that referenced a problem in the ESP but there was no fault captured for that module.

We will have to wait and see what happens. Short story, I am having concerns about the car. I have read about pre-collision assist issues which are concerning but nothing about the brake not working. That elevates my concern a few orders of magnitude. Unless they can find the specific point of failure and assure in writing it won't happen again, I don't think I will drive the car again.

Let me know if anyone has experienced something similar to this. I have done quite a few searched and found nothing online. The closest was a issue with the SLC/SLK where the ESP caused the brakes to drag against the rotors which I would result in serious brake fade.

Apologies for the quality of the pictures, I had to crop to avoid license plate information for the other party
 

Attachments

1 - 1 of 1 Posts
Top