Mercedes GLC Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
The internet radio on my Command Unit stopped working. I contacted Mbrace technical help and they were unable to fix the problem remotely. I took the car to the dealer and they tried to correct the software and contacted Germany for assistance. It was taking so long I took the car back, waiting for further notice from the dealer. About a week later the dealer advised they were going to replace the Command module in my car. It appears this has happened to other vehicles not just mine. Today, when they were supposed to do the work, Germany advised all the apps were down so the dealer was unable to test to see if the replacement worked. Hopefully I will know something tomorrow.

Just to advise that this is another potential problem.

2017 GLC43 AMG.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #2 ·
Update. They replaced my radio and module that controls the internet and it did not work. Now, Mercedes engineers are working on the issue. I was told that there are other customers affected by this problem. No idea, at this point, when this will be fixed.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Update 2. Still waiting for resolution of this issue. MB German is working on this issue and should be sending an update to my car. But do not know when this will happen. No internet service in my car until then.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Update 3

Well, the issue is still going on without resolution. I have learned that you need to press the i button once in a while to keep the connection to the car active. Also, supposedly 1 bar is not enough for a connection. I have been told that the signals coming to my car are all good and in Phoenix i can get 3 or more bars so everything should work. However, it still works poorly. I believe the Mbrace system for internet radio and such is just not that good. At least the WiFi does seem to work quite a bit better. Maybe a new model with Carplay is the answer. I still call them now and then to advise the system is not working.
 
1 - 4 of 4 Posts
Top