Mercedes GLC Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
I checked the oil on my 43 yesterday and was a bit surprised to find it had actually used some ( about a pint in 4K miles) but what really surprised me was that when you first remove the dipstick it doesn't show any oil at all and only when you replace it and then pull it out can you see the oil. I can't quite get my head around that , I've tried a couple, of times drive the car for a bit let it sit for a couple of minutes pull the stick out and no oil shows , dip it again and the oil is there. Magic ! Comments from other 43 owners welcome .


Andrew
 

·
Registered
Joined
·
265 Posts
Wheat's a dipstick Andrew? :wink2:

I wait for a message to tell me, and it hasn't happened yet after 9k
 

·
Super Moderator
Joined
·
1,154 Posts
Will check mine tomorrow Andrew.

Just to let you know, have swopped my 19's with summer tyres to 20's with winter tyres and the ride is actually better on the 20's.
 

·
Registered
Joined
·
76 Posts
3250 miles from new and oil still showing on max, 2018 GLC 43 AMG.
 

·
Registered
Joined
·
50 Posts
I checked the oil on my 43 yesterday and was a bit surprised to find it had actually used some ( about a pint in 4K miles) but what really surprised me was that when you first remove the dipstick it doesn't show any oil at all and only when you replace it and then pull it out can you see the oil. I can't quite get my head around that , I've tried a couple, of times drive the car for a bit let it sit for a couple of minutes pull the stick out and no oil shows , dip it again and the oil is there. Magic ! Comments from other 43 owners welcome .


Andrew

The day I took delivery of my factory ordered 43, I checked the oil before leaving the dealer. To my horror, there was no oil on the dipstick. I was about to go inside and give the service department a piece of my mind for not doing a proper pre-delivery inspection, but, decided I should double check the oil first. I put the dipstick back in, pulled it back out, and low and behold, the oil was at the "Max" mark.


Every time I check the oil it's like that. I'm glad to read that other 43's are like that too. I can't wrap my head around how that happens though.



As for oil consumption, mine doesn't seem to burn any. I now have 15,000 Km and the oil level is still at the "Max" mark like it was when I picked it up brand new.
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #6 ·
Update I somehow misread the dipstick , maybe I didn't push it right down so I| overfilled . I got my Lidl's oil pump out and sucked out a pint now sitting on the full mark so no oil consumption at all! Thanks to Mercnut for confirming that the dipstick comes up clean on the first pull , quite how that can be is a mystery.


Andrew
 

·
Super Moderator
Joined
·
1,154 Posts
Just checked the dipstick and as you said Andrew, no oil on first removal and then oil when replaced and removed, odd. Wonder if this is just on the 43.
 

·
Registered
Joined
·
55 Posts
Aus GLC250 ...pulled the dipstick …..first time!! ...all damp and oily on the bottom.

No need for the double shuffle! ……..must be a 6 cylinder thing!!
 
1 - 8 of 8 Posts
Top