Mercedes GLC Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This just started a few days ago. I tried using different phones, and a new wire, no luck. Any ideas short of going in to the dealer for a reset?
 

·
Registered
Joined
·
28 Posts
When we first got our car, CarPlay would work for a while and then the screen would pixelate, at which point I would restart the phone and it would start working again. At some point through IOS upgrades and GLC upgrades (presumably updated during the annual service) it now works without the periodic restart.
 

·
Registered
Joined
·
1 Posts
Connect your phone to the carplay via cable. While connected do a hard reset ( difference iPhones have various way of doing hard reset, so do a quick google search for your phone)
When doing the hard reset keep the reset buttons pressed in until you see the Apple logo appearing.
this should fix the scrambled CarPlay screen.
 

·
Registered
2019 GLC300
Joined
·
6 Posts
This just started a few days ago. I tried using different phones, and a new wire, no luck. Any ideas short of going in to the dealer for a reset?
This happened to me 3 days ago! I called my dealer and they said I needed to come in as it might be an "electronic issue", which was incorrect as when I got there a service tech told me this is a bug that MB is aware of. He said it's that the iPhone has so much info and the MB can't process it all. (?) Just shut down the iPhone and restart it. It worked! Good luck!
 

·
Registered
Joined
·
2 Posts
This happened to me before. It was fine after I restarted the iPhone. I don’t know if the phone system is incompatible with the car system. I don't know more, and it never happened again after that.
3435
 

·
Registered
2019 GLC300
Joined
·
6 Posts
This is still happening, and it seems to be happening more frequently. A hard reset of my iPhone seems to correct it, but how annoying is it to have to do this while driving? What is MB doing about this?
3451
 

·
Registered
Joined
·
1 Posts
I have the same problem with my iPhone 12...the screen "melts" almost every time I connect my iPhone to my GLC. Restarting the phone seems to help...but I have to do that EVERY time I plug in my iPhone. VERY annoying! Is Mercedes working on this?
 

·
Registered
Joined
·
1 Posts
I have the same problem with my iPhone 12...the screen "melts" almost every time I connect my iPhone to my GLC. Restarting the phone seems to help...but I have to do that EVERY time I plug in my iPhone. VERY annoying! Is Mercedes working on this?
 

·
Registered
Joined
·
2 Posts
This is still happening, and it seems to be happening more frequently. A hard reset of my iPhone seems to correct it, but how annoying is it to have to do this while driving? What is MB doing about this? View attachment 3451
I am having the same issue! I have an iPhone 12. Have you had any luck with a resolution?
I have also attempted to reset the phone and still no luck.
 

·
Registered
Joined
·
1 Posts
Connect your phone to the carplay via cable. While connected do a hard reset ( difference iPhones have various way of doing hard reset, so do a quick google search for your phone)
When doing the hard reset keep the reset buttons pressed in until you see the Apple logo appearing.
this should fix the scrambled CarPlay screen.
This worked for me, been driving me insane! Thank you for posting
 
1 - 11 of 11 Posts
Top